Application Login Error
Symptom:
When I try to log into my application, I receive one of the following errors:
  • Error while processing the request. Unable to process the request due to The issue might be due to maintenance downtime or capacity problems. Please try again later.
  • Currently we are experiencing technical difficulties...
Cause:
This issue may be caused by one or more of the following:
Resolution:
To resolve this issue, perform one or more of the following:
  • Navigate to the Application Center page (https://my.phoenix.edu/apply) and log in  
  • Clear the cache and cookies in the browser
  • Recover username using the Forgot login? link
Additional Information:

There is no additional information.

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