Unable to Make Payments by Credit/Debit Card
Symptom:
When entering payment amount and clicking Pay by Credit/Debit Card, the following error occurs:
  • The transaction cannot be processed as submitted. Please press Cancel to continue.
  • An internal occurred during processing
  • First name does not match
Cause:
To resolve the issue, perform one or more of the following:
Verify Address on File with Payment Source
  • Call your bank or credit card company and verify your exact address on file. EX: South, S., and S are all different. If your payment source has S on file and S. is entered on the CREDIT CARD PAYMENT INFORMATION it could be rejected by your payment source
Remove Any Commas in the Payment Amount Field

Note: As an alternative, you can contact your Finance Advisor directly to manually enter your payment.
Resolution:
To resolve the issue, perform one or more of the following:
Verify Address on Student Record
  1. Click the Account tab
  2. Click Change Address
  3. Click Edit on your PhoenixConnect Profile
  4. Update address as needed
  5. Click Save
Verify Address on File with Payment Source
  • Call your bank or credit card company and verify your exact address on file. EX: South, S., and S are all different. If your payment source has S on file and S. is entered on the CREDIT CARD PAYMENT INFORMATION it could be rejected by your payment source
Remove Any Commas in the Payment Amount Field
Note: As an alternative, you can contact your Finance Advisor directly to manually enter your payment.
Additional Information:
For additional information on payment attempts, please see the Related Articles section to the right.
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