Cannot be Identified on Password Reset
Symptom:
When attempting to reset my password I receive the following error(s):
  • We could not identify you based on the information provided. Please try again. 
    If problems persist, please call Technical Support at 1 (877) 832-4867.
  • An Unexpected Error Occurred 
    We are experiencing technical difficulties. Wait a minute and try again. 
Cause:
This may be caused by the following reasons:
  • More than one student IRN number associated to your account.
  • Missing Social Security Number (SSN) or Date of Birth (DOB)
  • Trying to reset your password for the incorrect username
  • Current password in the system does not meet complexity requirements 
  • Student's eCampus account has been deactivated due to inactivity
Resolution:
Please contact Technical Support for assistance investigating the cause(s) of the issue.
Additional Information:
There is no additional information.
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