Resetting MyEducator Password
Symptom:
I am unable to submit the Microsoft Office Word document provided by MyEducator because I do not know my MyEducator password.
Cause:
Your MyEducator password needs to be reset.
Resolution:
To reset your MyEducator password, please follow these steps:
  1. Access the Classroom and select any chapter from MyEducator
  2. In the upper-right corner of MyEducator, click on your name
  3. Select My Account
  4. Select the Password tab
  5. Click the Password reset link
  6. Enter your student email address (USERNAME@email.phoenix.edu)
  7. Access your student Inbox
  8. Located the Password Reset email from MyEducator and reset the password
  9. Submit the Word document using your new MyEducator password
Additional Information:
There is no additional information.
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