Error Registering on Application Center
Symptom:
The following error is received when I attempt to use the Application Center registration link provided by my Enrollment Representative:
Error: Server is currently unable to complete your request
Cause:
One or both of the following could case this error:
  • The provided link did not properly associate to your account
  • Multiple IRNs are assigned to you
  • Corrupted cache and cookies
Resolution:
To resolve this issue, please perform one of the following:
  • Request the Enrollment Representative email you a new Application Center registration link
  • Clear cache and cookies in the browser you are using or switch to another browser
  • Request the Enrollment Representative verify there are no other IRNs associated to you and the information that you are entering matches the information in our system.
    Note: If there are, the representative will need to submit an IRN Merge request before you will be able to proceed.
Additional Information:
For additional information on registering on Application Center, please see the Related Articles section to the right.
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