Unable To the Financial Plan
Symptom:
When I click on the Financial Plan tab, it never finishes loading.
Cause:
This is usually caused by browser issues such as cache and cookie corruption, but causes can vary.
Resolution:
To resolve this issue, perform the following standard browser troubleshooting:
  • Clear Phoenix cookies
  • Clear all cache and cookies
  • Navigate to eCampus by typing ecampus.phoenix.edu directly in the address bar
  • Disable any conflicting browser extensions
  • Use an alternate browser
  • Powercycle the Internet Connection
  • Wait and try later if issue is due to maintenance, outage, or other temporary internal system issue 
Additional Information:

For additional information, please see the related article(s).

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