Films on Demand Links Not Working
Symptom:
When I attempt to access a link to a Films on Demand segment provided by my faculty, I am getting an error or login prompt.
Cause:
This happens when the incorrect URL is used to link to the video or segment.
Resolution:
In order for Films on Demand links to work, the permalink address (Title URL or Segment URL depending on whether you want the whole playlist or a single video) shown toward the bottom of the page must be used rather than the URL in the address bar. The URL in the address bar is missing the institution ID that lets you view the content without being directly logged in to the site.
Note: If you can not find the video that you are looking for perform the follow:
  1. Click Library
  2. Select University Library
  3. Click Databases A-Z tab
  4. Search for Films on Demand
  5. Click Films on Demand
  6. Search for desired video
Additional Information:
There is no additional information.
We welcome and appreciate your feedback!
Share
Subscribe
Enter your email address to receive a notification when the article is updated
Email Address
Subscribe
Unsubscribe
Share
To
Subject
Message
Send

Was this article helpful
Thank you for your feedback
How can we improve?