Account Summary Incorrect
Symptom:
My Account Summary page is not showing recent activity.
Cause:
This issue may be caused by the replication time from the financial systems.
Resolution:
For replication periods, please review the following:
Account Summary:
  • Please allow up to 48 hours for recent activity to reflect on the Account Summary page.
Account History:
  • Please allow up to 20 minutes for recent activity to reflect on the Account History page.
Note: The replication periods are indicated on their respective pages in red text.

Note: If the replication time has past please contact the Student Financial Services team to verify recent activity on your account.
Additional Information:
For additional information on the Account Summary page, please see the Related Articles section to the right.
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