Page Cannot Be Displayed Error When Accessing an eBook
Symptom:
When opening an eBook from Materials page, the following error occurs:
Page cannot be displayed
Cause:
One or more of the following may cause this issue:
  • The eCampus website was accessed using a bookmark, Favorite, or shortcut
  • The Internet connection was lost
  • Corrupt browser cache/cookies
Resolution:
To resolve this issue, perform one or more of the following:
  • Log out of eCampus, restart your browser, & try again
  • Verify Internet connectivity by going to a different website
    • Note: If you are not able to load any additional website please contact your Internet Service Provider directly for assistance.
  • Clear cache & cookies in browser
Additional Information:
For additional information on clearing browser cache and cookies, please see the Related Articles section to the right.
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