Maximum Number of Attempts Error when Paying Bills
Symptom:
When attempting to pay bills using a credit or debit card, the following error occurs:
You have exceeded the maximum number of attempts while processing a credit/debit card transaction. Please contact your financial advisor for assistance. Please press "Cancel" to continue.
Cause:
This is caused by entering an incorrect card number or expiration date. This can also be caused by using a card that has expired.
Resolution:
You will need to allow 24 hours to attempt to pay using the correct card information. If after 24 hours and verifying that you are entering correct information you are still unable to submit a payment, you will need to contact Technical Support.

If you need to pay the bill immediately, you may contact your Finance Advisor.

Additional Information:
For additional information on contacting Technical Support, please see the Related Articles section to the right.
We welcome and appreciate your feedback!
Share
Subscribe
Enter your email address to receive a notification when the article is updated
Email Address
Subscribe
Unsubscribe
Share
To
Subject
Message
Send

Was this article helpful
Thank you for your feedback
How can we improve?